WordPress开启HTTPS后正文图片改为HTTPS两种方法

WordPress 站点开启 HTTPS 后,文章中引用的图片就很有必要把 HTTP 统一改为 HTTPS,要不然会地址栏上的绿锁就会有黄色的三角,感觉是很不爽的。为了解决这个问题,我们有两种方法:一个是治标不治本的办法,就是在主题的  functions.php 文件中加入字符替换语句,这样读者在每次访问的时候会相应的把图片的 http 链接替换为 https,而数据库的原始内容不变;另一个彻底根治的办法是,直接进入数据库用 SQL 语句把 HTTP 直接替换为 HTTPS。下面老文笔记就这两个方法本文做简单介绍:

WordPress开启HTTPS后正文图片改为HTTPS两种方法 - 第1张 - boke112联盟(boke112.com)

方法一:通过主题的 functions.php 文件来批量替换

在主题文件的 functions.php(WP后台“外观”-“编辑”右侧可以找到)里加入如下代码(注意域名需要做相应修改)

/* 替换图片链接为 https */
/* 来源(https://www.wenrr.com/): */
function https_image_replacer($content){
if( is_ssl() ){
/*已经验证使用 $_SERVER['SERVER_NAME']也可以获取到数据,但是貌似$_SERVER['HTTP_HOST']更好一点*/
$host_name = $_SERVER['HTTP_HOST'];
$http_host_name='http://'.$host_name.'/wp-content/uploads';
$https_host_name='https://'.$host_name.'/wp-content/uploads';
$content = str_replace($http_host_name, $https_host_name, $content);
}
return $content;
}
add_filter('the_content', 'https_image_replacer');

PS:老文认为应该不用那么复杂,直接使用以下代码可能会更加简练一些,毕竟大家的域名基本上都是固定的。

function replacehttp($content){
if( is_ssl() ){
$content = str_replace('http://域名/wp-content/uploads', 'https://域名/wp-content/uploads', $content);
}
return $content;
}
add_filter('the_content', 'replacehttp');

方法二:通过 SQL 语句进行正文的批量替换

PS:操作前请务必对数据库进行备份,以避免不可挽回的数据丢失!

WordPress开启HTTPS后正文图片改为HTTPS两种方法 - 第2张 - boke112联盟(boke112.com)

运行如下语句批量替换:

UPDATE wp_posts SET post_content = replace(post_content, 'http://域名/wp-content/uploads','https://域名/wp-content/uploads');

PS:记得将以上语句中的域名及路径个自己的,如果更改过数据库表的前缀,还要记得修改wp_为自己的前缀哦。

关于WordPress开启HTTPS后正文图片改为HTTPS两种方法的相关内容;如有侵权,请联系老文删除。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
老文的头像老文
上一篇 2021年9月27日 上午11:19
下一篇 2021年10月7日 上午1:26

相关推荐

  • zblog后台的应用中心登录不了 提示错误怎么办?

    最近突然有些用户反应自己的zblog网站后台里面的应用中心登录不了,提示错误。 我们先不谈错误,先来谈下后台应用中心登录的正确步骤: 第一步:打开后台–点击应用中心–点击登录应用商城,如下图所示: 第二步:应用中心登录需要你输入令牌,点击上图的“点击获取账户登录令牌”跳转到“ https://uc.zblogcn.com/user/s…

    2021年11月18日
    795
  • WordPress“正在执行例行维护,请一分钟后回来”解决方法

    在WordPress 3.X的版本当中,加入了升级维护的显示功能。例如WordPress网站正在升级或者安装、升级插件的时候,访问首页将会显示“正在执行例行维护,请一分钟后回来。”如果一切顺利,这个显示将会过一段时间后消失变为正常的首页。但也有例外,有时候即使是安装成功了,这个提示也会一直存在。 解决方法: 请先通过FTP进入WordPress网站根目录,看…

    2021年8月12日
    494
  • WordPress上传的文件尺寸超过php.ini中定义的upload_max_filesize值解决方法

    WordPress上传主题包时,提示“上传的文件尺寸超过 PHP.ini 中定义的 upload_max_filesize 值”。 问题原因是php.ini文件里限制了最大上传文件大小,默认为2MB,解决方法找到这个文件按照下文方法稍微修改一下即可。 1、一般来说VPS服务器的话,就是找到php.ini这个文件,然后修改里面几个参数即可。php.ini的路径…

    2021年11月7日
    543
  • 网站数据库经常无故暂停的问题排查和解决方案

    遇到一个朋友,估摸着也是才开始学习搭建网站的。而且他心还是比较大的,选择到一台云服务器,然后一骨碌搭建四五个网站。于是出现的故障也随之而来,他这几天网站每天都有好几次出现数据库连接不上的问题,需要重启数据库才可以恢复。 像这种数据库经常无故暂停的问题也是常有的。这个到底是什么问题影响的呢,有没有解决办法。 第一、服务器的利用率 这个同学一台1G内存的服务器,…

    2022年3月26日
    694
  • DZ论坛UCenter后台通信失败彻底解决方法(亲测有效)

    前面在论坛分享过discuz论坛更换目录后出现头像无法显示/ucenter无法进入,只是简单地讲了在更换子目录之后怎么重新设置参数,使得头像正常显示。 但是今天在迁移一个新的站点的时候发现ucenter彻底无法进入,直接是空白显示,如图。 另外全站会员都没法加载头像,图片显示失败。 这时候我考虑到是UCenter的链接是有问题的,但是我的uc_server文…

    2024年7月31日 建站知识
    344